Ubuntu: swfdec using ffmpeg in PPA

I created a version of swfdec 0.6.6 using mad and ffmpeg instead of gstreamer, because with gstreamer it failed to play multiple videos on youtube.com.

The release is available in my PPA at:

deb http://ppa.launchpad.net/juliank/ubuntu hardy main
deb-src http://ppa.launchpad.net/juliank/ubuntu hardy main

I will also provide some builds of the development branch (0.7.1) soon.

Update:Maybe it was not clear, but the videos crashed the browser. It also didn’t really work in totem and I’m still looking for the source of the problem. I have every available gstreamer plugin package installed. Try it yourself, http://de.youtube.com/watch?v=CSp7jsV7oG0. It works with gnash, but gnash does not work with wordpress stats page.

Update 2: I now found the real problem: I had an binary version of fluendo’s mp3 plugin installed (from fluendo.com), which caused the crash. After removing the file, everything works. (using fluendo-mp3 shipped with Ubuntu).

Update 3: I removed the ffmpeg version from my PPA, as it is not needed.

4 thoughts on “Ubuntu: swfdec using ffmpeg in PPA

  1. Sounds like you are ignoring recommends, and are missing the gst-ffmpeg decoder plugins. Would have been much easier to just install these then rebuilding with a not-recommended configuration. :/

  2. Works fine for me, so nothing I can help you with. Could you get a backtrace and file a bug at https://bugs.freedesktop.org please?
    It’s also in your own best interest, because swfdec 0.7 will likely not have the ffmpeg and mad options for a lot longer. I intend to rip them out because GStreamer works so well.

    your friendly Swfdec developer.

  3. Hi!

    I’ve installed latest version (0.7.1) from this repo, but, even if I’ve removed flashplugin-nonfree, I don’t managed to associate swfdec with flash file…

    Anyone can help me, please? 😉

Comments are closed.